Angels Online Today: 3    Total Posts: 128096

Total:#5

Create Thread

[General Discussion] Angels Online won't update nor open.

[Copy link] 4/425

#1
Posted on 2018-10-08 19:17:45 | Show thread starter's posts only

EDIT: I have already uninstalled and re-installed multiple times. Same result.
I also tried to play on a Windows 8 laptop and another Windows 10 laptop just to check if it was my laptop. The error pops up on every laptop.


Hello.

First of all, I am very sorry if this thread is not on the right place.
Second, I have contacted IGG via the service center and they keep saying to do something I have already tried.

Now, back to the problem.

I have installed Angels Online on version 7.6.1.0 because that appears to be the latest on the official website.

Everything was fine then, I installed the game and when I opened the launcher, boom.
Error.

The error says: "Failed to load the latest update information, please download the latest update pack from the official website (http://ao.igg.com/) to update manually."



As you can see in the image, I have already installed all the patches from 7.6.1.0 to 7.6.1.6.



Yes, I also installed patches 7.6.1.1 and 7.6.1.2 although they do not appear on the website.
I tried without these two patches (only with the patches on the page) and the error persists.


I would really appreciate if anybody could give me a solution.

I am running the game on a Windows 10 laptop, Intel Core i3-8130U 2.20GHz 2.21GHZ processor, 4GB ram, 64 bits.

Thank you.

Signature
Doing what I want.
#2
Posted on 2018-10-09 04:37:45 | Show thread starter's posts only

Are you running as administrator?

If you are, disable your antivirus and try again.

If it doesn't work, wait until next maintenance and try again

Signature
#3
Posted on 2018-10-10 11:50:45 | Show thread starter's posts only

Hi, I have same problem before. but,...

http://ao.igg.com/download/download_link.php?id=117

try this link, this link is very old, like years old. this is the link that i used to download the game few weeks ago. enjoy!

Signature
#4
Posted on 2018-10-15 10:29:07 | Show thread starter's posts only

I waited for the update and it hasn't fixed the issue.

IGG Service Center can't do anything about it either.

Signature
Doing what I want.
#5
Posted on 2018-10-16 09:52:25 | Show thread starter's posts only

Apparently the Multi Launcher opens the game and I can play for a while until it crashes.

Signature
Doing what I want.